Release Preview Test Plan 1
Overview of Release Preview

Release Preview Test Plan
The Release Preview Test Plan includes the following sections:
• Overview of Release Preview
• Preparing for Testing
• Recommended Test Plan

Test Plan Template Available for Download
Download the Release Preview Test Plan Template to create your workflow test plan.
This Microsoft Excel worksheet includes a Testing Matrix, Workflow worksheets,
and examples. After downloading the file, modify it to suit your testing needs.
ReleasePreviewTestPlan_Template.xls.

Overview of Release Preview
The Release Preview environment enables you to become familiar with the new features in an
upcoming release. You can verify that your existing business workflows function as expected
before upgrading the production account. You can also use the Release Preview environment to
test and ensure your NetSuite account and any associated applications are not dependent on a
specific data center to store data. You can evaluate your applications for any data center-specific
identifiers, and replace them with data center agnostic information.
Our goal is to provide a smooth and seamless transition to a new release. We hope that by
making this information available, working with you to ensure you perform the recommended
tests, and providing other needed guidance, we will avoid any major problems or surprises
when you go live with the new version.
To help you get the most out of your Release Preview, review the following topics:
• Preparing for Testing includes the following sections:
• Setting Preferences for Release Preview Email
• Accessing Your Release Preview Environment
• Functionality Available for Testing
• How to Report Release Preview Issues
• Recommended Test Plan includes the following sections:
• Test Business Workflows
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• Test Custom Reports and Forms
• Test SuiteScript
• Test SuiteTalk (Web Services) Integrations
• Test Installed SuiteApps
• Test Your Web Store
• Test SuiteAnalytics Connect

Note: Performance in your Release Preview environment is not always on par with your
production account. You can expect that the first few times you complete a process
or task, such as entering a sales order, performance will be a bit slow. You should
experience faster performance as you repeat the process or task through several
iterations of testing. Release Preview is intended for testing the functionality of new
features, not as a performance measurement tool for the new version.

Preparing for Testing
Download the Release Preview Test Plan Template to create your workflow test plan.
This Microsoft Excel worksheet includes a Testing Matrix, Workflow worksheets,
and examples. After downloading the file, modify it to suit your testing needs.
ReleasePreviewTestPlan_Template.xls.

Important: As you prepare for testing in Release Preview, make a note of the various
scheduled events that run in your production environment. These scheduled
events should be disabled before the account is upgraded to the new release,
and enabled after the upgrade is complete.
See the Version 2015 Release 2 Sneak Peeks and the Version 2015 Release 2 Release Notes so that
you have time to review new or changed functionality well before the release.

Note: Links to the Sneak Peeks and Release Notes are also available from the New Release
portlet.
To prepare for testing in Release Preview, review the following sections:
• Setting Preferences for Release Preview Email provides instructions for controlling email
generation from the Release Preview environment.
• Accessing Your Release Preview Environment details how to access your Release Preview
environment so that you can familiarize yourself with the new features and changes in this
release.
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• Functionality Available for Testing contains a table of the features that can be tested in
Release Preview.
• How to Report Release Preview Issues explains what to do if you encounter an issue.
• Test Business Workflows explains how to document your critical daily workflows to
help you create tests that ensure you will not encounter anything unexpected when your
account is upgraded to the new version.

Setting Preferences for Release Preview Email
Account administrators can set a preference for delivery of email messages for the Release
Preview environment in the production account, and also set your preferences directly in the
Release Preview environment on the Printing, Fax & Email Preferences page, on the Email tab.
For example, during testing you might not want customers to receive email messages from
the Release Preview environment. In this case, you may want email from your Release
Preview environment delivered only to yourself, or to the people in your organization who are
responsible for testing.

To set email delivery preferences for Release Preview:
1.

Log in to your NetSuite production account.

2.

Go to Setup > Company > Printing, Fax & Email Preferences.

3.

Click the Email subtab.

4.

Choose your preference in the Sandbox and Release Preview section. Under Release
Preview Options, choose from the following:
• Send Email To – Enter the address where email messages should be delivered.
You can enter multiple email addresses separated by commas. This preference is
recommended, as it enables you to specify each email address for routing email
messages from Release Preview.
• Send Email to Logged in User –Choose this option to route all email messages only
to the person logged in to the Release Preview environment.
• Do Not Send Email – Choose this option if you do not want email messages sent
from the Release Preview environment.

5.

Click Save.

6.

The email delivery preferences you set in your production environment will be applied to
your Release Preview environment.
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Important: Release Preview is a copy of your production account as of a certain
date, so the data in Release Preview may not be the same as in your
production account. If you recently changed your Release Preview email
preferences in your production account, they may not be reflected in the
snapshot used to generate your Release Preview environment. Complete
the following steps to verify the email preferences in the Release Preview
environment.
7.

Log in to your Release Preview environment.

8.

Go to Setup > Company > Printing, Fax & Email Preferences.

9.

Click the Email tab.

10.

Verify your email preferences in the Sandbox and Release Preview section, and if
necessary, modify them appropriately.

Note: To decrease the number of automatic email notifications, all saved searches in the
Release Preview environment are set inactive by default. If you want to enable
email notifications for a specific saved search, you can activate it. To learn more
about deactivating and activating a saved search, see the help topic Mark a Search
Inactive.

Accessing Your Release Preview Environment
The Primary Contact and the Product Update contacts for your account receive several
notifications (by email, and upon login) in the weeks before the scheduled Release Preview
start date. These notifications contain details on the Release Preview and Upgrade dates, and
announce the day the Release Preview environment is available for testing to begin.

To access Release Preview from the URL:
1.

Go to https://system.na1.beta.netsuite.com.

2.

Log in using your NetSuite email address and password.

3.

Read the NetSuite Release Preview Agreement and click Continue to accept the terms
and access the Release Preview software.

To access Release Preview from the New Release portlet:
The New Release portlet is usually located on your home page dashboard in your production
account. If you do not see the portlet, see Adding or Restoring the New Release Portlet.
1.

Log into your production account (https://system.netsuite.com).

2.

Locate the New Release portlet on your home page.

3.

Click Release Preview Login (the key-shaped icon).
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4.

Log in using your NetSuite email address and password.

5.

Read the NetSuite Release Preview Agreement and click Continue to accept the terms
and access the Release Preview software.

Refer to the Version 2015 Release 2 Sneak Peeks and the Version 2015 Release 2 Release Notes
documents for information about the new features in this release.

Adding or Restoring the New Release Portlet
To add or restore the New Release portlet to your dashboard:
1.

Click Personalize on your Home page.

2.

On the Standard Content tab, select New Release.

Note: Your Release Preview environment is completely separate from your NetSuite
production account. Release Preview is a temporary and isolated test environment
that is running the new version of NetSuite software. Use Release Preview only for
testing. Be sure your are logged in to your NetSuite production account when you
are performing your daily business activities.
The isolation of Release Preview from other environments means, for example, that a SuiteApp
(a bundle) created in Release Preview cannot be installed in a Production or Sandbox
environment, even if it has been copied to the bundle repository.

Functionality Available for Testing
The following table describes functionality available for testing in the Release Preview. Only
modules that you have purchased and enabled in your production account will be available
in your Release Preview. Be sure you understand the limitations of the Release Preview
environment.

Note: “No actions taken” in the Limitations column indicates the feature is available, but
no emails are sent, no campaigns are executed, and no payments are processed.
Feature

Availability

Limitations

Integrations
CSV Import

Yes

SuiteAnalytics Connect Yes
(formerly ODBC)
Web Services

Yes

Customizations
Client SuiteScript

Yes

Custom Records

Yes

Scheduled SuiteScripts

Yes

Scripts will not execute as scheduled, but can be executed
manually.
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Feature

Availability

Server SuiteScript

Yes

Limitations

Partner Integrations
ACH Vendor Payments

Yes

No actions taken

Alternative Payment
Methods

Test-mode only

No actions taken (No payment sent). The test mode is turned
on for all payment processing profiles.

Credit Card Processing

Test-mode only

No actions taken

Important:

CTI Integration
(Contactual, Five9)

Yes

Direct Deposit

Yes

No actions taken

eBay Integration

Yes

No actions taken

Electronic Funds
Transfer

Test-mode only

No actions taken

Intellesync

Yes

Online Bill Pay

No

Outlook Integration

No

Payroll

Yes

No actions taken

PayPal Integration

Test-mode only

No actions taken

Perquest

Yes

No actions taken

Telephony Integration
(Basic)

Yes

UPS/FedEx Integration
for Shipping labels

Test-mode only

UPS/FedEx Integration
for Rate querying

Yes

Recent security enhancements to the
processing of credit card information in
NetSuite now require that an account
administrator enter and save the
authentication credentials on your credit
card processing profiles before credit card
transactions can be processed in Release
Preview. See Credit Card Processing in
Release Preview for more information.

Automatically disabled in Release Preview.

No actions taken

Miscellaneous Product Areas
Bulk Merge

No

No actions taken

Email Campaigns

No

No actions taken

Email Case Capture

Yes

Email Notifications

Yes

Saved searches are automatically set to inactive in the Release
Preview. For email routing options, see Setting Preferences for
Release Preview Email.
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Feature

Availability

Limitations

Fax

No

Memorized
Transactions

No

No actions taken

Saved Searches

Yes

Automatically set to inactive status in the Release Preview
to decrease the number of automatic email notifications
caused by the existing scheduled saved searches and
email notifications. For email routing options, see Setting
Preferences for Release Preview Email.

Scheduled Saved
Searches

Yes

Automatically set to inactive status in the Release Preview.
For email routing options, see Setting Preferences for Release
Preview Email.

Secure Domains

No

Automatically disabled in Release Preview.

SuiteFlow

Yes

Workflows triggered as a part of UI events will execute.
Scheduled SuiteFlows (Workflows, Scheduled Transitions
and Scheduled Actions) are automatically disabled in Release
Preview.

Token-based
Authentication

Yes

Tokens created using NetSuite’s Token-based Authentication
feature in the production environment are not copied to
Release Preview. To test this feature, you must create new
tokens in the Release Preview environment.

Two-Factor
Authentication

Yes

Do not make any changes to tokens in Release Preview, as
they are copied from your production environment. The
tokens are managed by a single RSA server, so changes
made in Release Preview will also affect your production and
sandbox environments.

Web Site

Yes

Web Store

Yes

Credit Card Processing in Release Preview
Recent security enhancements to the processing of credit card information in NetSuite now
require that an account administrator complete the following procedure to process credit card
transactions in your Release Preview environment.

To enable credit card processing profiles for use in Release Preview:
1.

Log in to your Release Preview environment (https://system.na1.beta.netsuite.com).

2.

Go to Setup > Accounting > Financial Statements > Payment Processing Profiles.

3.

Click Edit next to the credit card processing profile you want to use in Release Preview.

4.

On the credit card processing profile, under Authentication Credentials, enter the
credentials required for this processor.

5.

Click Save.
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6.

Repeat these steps for each credit card processing profile you want to use in your Release
Preview environment.

How to Report Release Preview Issues
Report any issues you encounter during testing by calling NetSuite Support or by submitting a
case online.

Call NetSuite Support
Use one of the phone numbers in the following table to call NetSuite Support:

Note: These phone numbers are in the United States. If your are calling from a country
that is not part of the North American Numbering Plan, include the appropriate exit
code for your country.
Region

Phone Number

All Locations

1.877.774.4271

US - local

1.925.948.1084

To submit a case:
1.

Click the Support tab.

2.

Click Go to SuiteAnswers.

3.

Click the Contact Support Online link and provide details of your issue.
A case will be created in the NetSuite Support system under your accounts that will be
flagged as a problem in the Release Preview environment.

Recommended Test Plan
Download the Release Preview Test Plan Template to create your workflow test plan.
This Microsoft Excel worksheet includes a Testing Matrix, Workflow worksheets,
and examples. After downloading the file, modify it to suit your testing needs.
ReleasePreviewTestPlan_Template.xls

Important: As you test in Release Preview, make a note of the various scheduled events
that run in your production environment. These scheduled events should
be disabled before the account is upgraded to the new release, and enabled
after the upgrade is complete.
The following sections provide a plan for thoroughly testing your account in Release Preview:
• Test Business Workflows explains how to document daily workflows, and provides a link
to a sample test plan.
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• Test Custom Reports and Forms
• Test Other Customizations
• Test SuiteScript
• Test SuiteTalk (Web Services) Integrations
• Test Installed SuiteApps
• Test Your Web Store
• Test SuiteAnalytics Connect

Test Business Workflows
In order to test successfully in Release Preview you should identify, document, and test the key
business workflows (not to be confused with SuiteFlow workflows) in your production account.
Testing your workflows is the most important aspect of Release Preview. Compile a list of the
critical task paths your employees follow to get their jobs done and create a document for each
process. We recommend that you use a spreadsheet application and create a separate worksheet
for each common daily task. Use this spreadsheet as your checklist during testing.
Download the Release Preview Test Plan Template to create your workflow test plan.
This Microsoft Excel worksheet includes a Testing Matrix, Workflow worksheets,
and examples. After downloading the file, modify it to suit your testing needs.
ReleasePreviewTestPlan_Template.xls
At minimum, each business workflow documented should contain the following components:
• Business Workflow Name – Provide a unique name.
• Role – Specify the role to use when testing the process.
• Email – Specify the email address to use for testing.
• Steps – Provide the detailed navigation required to accomplish the desired task.
• Results – List expected results.

Test Custom Reports and Forms
Important: During the testing of your business workflows, you might have thoroughly
tested your custom reports and forms. If you think there are areas that might
have been overlooked in the workflow testing effort, review the information
in this section. Add tests as needed to your plan.
Pay particular attention to any Customized Reports, Customized Forms, Custom Record
Types, Custom Searches, or bulk operations such as billing, shipping, and fulfillments. Compile
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checklists of reports, forms, record types, and other customizations from your production
account.

To test custom reports and forms:
Note: Performance in the Release Preview environment may differ from your production
account because it runs on different hardware. If your reports or searches run
more slowly in the Release Preview, reduce the date ranges for those searches and
reports. Your testing goal is to ensure that everything functions as expected: the
filtering, formulas, and the sorting of each report or search.
1.

Create checklists for various customized reports, forms, record types, and searches. See the
following sections for specific procedures for creating checklists.

2.

Test each form, each script, and each report that uses a formula to ensure they behave as
expected. If any customized form, script, or report uses a formula, ensure the formula
results are the same as in your production account. For example, run the identical report
in your production account and in the Release Preview environment. Compare formula
columns from the two reports to verify that the results are the same. Check off each item
in your checklists after testing.

Important: Release Preview is a copy of your production account as of a certain
date, so the data in it may not be the same as in your production
account. We recommend that you generate reports using date ranges
that can be compared between both accounts.
3.

Verify that any custom fields or custom record types function as expected. For example,
for each custom record, ensure that:
• Add and Delete behavior is the same as in the production account
• A record is linked appropriately to a parent record
• Formulas and forms function as expected

4.

Check Dashboard functionality: KPIs, KPI Scorecards, Report Snapshots, and other
customizations.

5.

Test your custom business workflows from start to finish. See Test Business Workflows for
more information.

6.

Test Suitelets and custom dashboard portlets. If these customizations do not use
SuiteScript UI Objects, and if you have written custom HTML, verify they work as
expected in the Release Preview environment.

To create a checklist for testing Transaction Forms customizations:
1.

Go to Customization > Forms > Transaction Forms.
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2.

Export this list to a .csv or .xls file.

3.

Review the list, and remove any items labeled Customize in the Edit column, as those are
NetSuite defaults.

4.

Save this modified list as your checklist for testing.

To create a checklist for testing Entry Forms customizations:
1.

Go to Customization > Forms > Entry Forms.

2.

Export this list to .csv or .xls.

3.

Review the list, and remove any items labeled Customize in the Edit column, as those are
NetSuite defaults.

4.

Save this modified list as your checklist for testing. Make a note of any form that is linked
to SuiteScript and Script Libraries, and ensure you test these forms.

Note: It is not necessary to test custom forms that you no longer use.

To create a checklist for testing Record Types customizations:
1.

Go to Customization > Lists, Records & Fields > Record Types.

2.

Record types cannot be exported, so we recommend you make a list of them in an Excel
spreadsheet to use as a checklist to ensure that you test each record type.

To create a checklist for testing Lists, Records, and Fields customizations:
Note: Most of these lists will be visible when testing your forms, but make note of them
for reference.
1.

Go to Customization > Lists, Records & Fields > Lists.
If desired, export this list to .csv or .xls. Save this list as your checklist for testing.

2.

Go to Customization > Lists, Records & Fields > Entity Fields.
If desired, export this list to .csv or .xls. Save this list as your checklist for testing.

3.

Go to Customization > Lists, Records & Fields > Item Fields.
If desired, export this list to .csv or .xls. Save this list as your checklist for testing.

4.

Go to Customization > Lists, Records & Fields > CRM Fields.
If desired, export this list to .csv or .xls. Save this list as your checklist for testing.

5.

Go to Customization > Lists, Records & Fields > Transaction Body Fields.
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If desired, export this list to .csv or .xls. Save this list as your checklist for testing.
6.

Go to Customization > Lists, Records & Fields > Transaction Column Fields.
If desired, export this list to .csv or .xls. Save this list as your checklist for testing.

7.

Go to Customization > Lists, Records & Fields > Transaction Item Options.
If desired, export this list to .csv or .xls. Save this list as your checklist for testing.

8.

Go to Customization > Lists, Records & Fields > Item Number Fields.
If desired, export this list to .csv or .xls. Save this list as your checklist for testing.

9.

Go to Customization > Lists, Records & Fields > Other Custom Fields.
If desired, export this list to .csv or .xls. Save this list as your checklist for testing.

To create a checklist for testing Reports and Saved Search customizations:
1.

Go to Reports > Saved Reports > All Saved Reports.

2.

This data cannot be exported. Make a list of all your customized reports in an Excel
spreadsheet to use as a checklist.

3.

Go to Reports > Saved Searches > All Saved Searches

4.

This data cannot be exported. Make a list of all your customized searches in an Excel
spreadsheet to use as a checklist.

Test Other Customizations
Important: During the testing of your business workflows, you might have thoroughly
tested all your customizations. If you think there are areas that might have
been overlooked in the workflow testing effort, review the information in this
section. Add tests as needed to your plan.
How you test other customizations depends on who implemented the customization and
whether you are still engaged with that company.
For NetSuite Professional Services Customizations:
• If you are still engaged with NetSuite Professional Services on this work, please contact
them or inform NetSuite Support. Support will make Professional Services aware of your
Release Preview dates so that they can coordinate testing with you.
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• If the custom work has been signed off by you and you use it in your day-to-day routine,
engage your internal person who maintains the customization to test it out in Release
Preview.
For Third-party (Independent Software Vendor) Customizations:
• If you are still engaged with the third-party on this work, we recommend you make them
aware of your Release Preview dates and request their assistance in testing the custom
work.
• If the custom work has been signed off by you and you use it in your day-to-day routine,
engage your internal person who maintains the customization to test it out in Release
Preview.

Test SuiteScript
Important: During the testing of your business workflows, you might have thoroughly
tested your SuiteScripts. If you think there are areas that might have been
overlooked in the workflow testing effort, review the information in this
section. Add tests as needed to your plan.
Read the SuiteScript release notes for details on API changes.

To test SuiteScript:
1.

Go to Customization > Scripting > Scripts.
List all scripts in an Excel spreadsheet to use as a checklist to ensure that you test each one.

2.

Go to Customization > Scripting > Script Deployments.
List all script deployments in an Excel spreadsheet to use as a checklist to ensure that you
test each one.

3.

Go to Customization > Scripting > Scripted Records.
List all scripted records in an Excel spreadsheet to use as a checklist to ensure that you test
each one.

4.

Test all of your operational SuiteScripts for compatibility and to ensure they are working as
expected.

5.

If you find any issues with your Server SuiteScripts you can put the script deployment in
testing mode and use the debugger on the na1.beta domain to investigate the problem.
The SuiteScript Debugger URL for your Release Preview environment is https://
debugger.na1.beta.netsuite.com
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Important: Changes you make to your account while in the debugger.na1.beta
domain will affect your Release Preview environment only and will NOT
affect your production account.

Test SuiteTalk (Web Services) Integrations
Important: During the testing of your business workflows, you might have thoroughly
tested your SuiteTalk (web services) integrations. If you think there are areas
that might have been overlooked in the workflow testing effort, review the
information in this section. Add tests as needed to your plan.
Test any operational web services integration processes for compatibility with the new release.
If you are engaged with a partner for any of your web services integrations, please contact them
and inform them of your Release Preview dates so that they can provide a time and test plan to
test the integration.
To test your web services application in the Release Preview environment, change the version
number and add .na1.beta. to your endpoint URL.
For example, change the URL from:
https://webservices.netsuite.com/services/NetSuitePort_2014_2

to:
https://webservices.na1.beta.netsuite.com/services/NetSuitePort_2015_1

If you have already made changes to ensure your account is data center agnostic, for example,
your web services are using the getDataCenterUrls operation, you will not need to make any
other changes to test in Release Preview.

Warning: If your production web services calls fail in Release Preview, this indicates that
they may contain hard-coded URLs. Hard-coding URLs prevents the data center
from being discovered dynamically.
Use Release Preview as an opportunity to identify data center specific URLs in your web
services code, and modify your production code to use data center agnostic auto discovery
operations such as getDataCenterUrls.

Important: If you have hard-coded URLs in your web services calls , and choose not to
modify your production code to use dynamic discovery operations, your web
service calls will fail when your account is moved to a different data center.
For more information on making your account data center agnostic, see the
help topic Understanding Multiple Data Centers.

Note: NetSuite officially supports web services versions for three years.
The most recent (General Availability) web services versions include:
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• https://webservices.na1.beta.netsuite.com/wsdl/v2015_1_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2014_2_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2014_1_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2013_2_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2013_1_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2012_2_0/netsuite.wsdl
The following web services versions are considered to be deprecated:
• https://webservices.na1.beta.netsuite.com/wsdl/v2009_2_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2009_1_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2008_2_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2008_1_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2_6_0/netsuite.wsdl
• https://webservices.na1.beta.netsuite.com/wsdl/v2_5_0/netsuite.wsdl

Test Installed SuiteApps
Important: During the testing of your business workflows, you might have thoroughly
tested your SuiteApps Integrations. If you think there are areas that might
have been overlooked in the workflow testing effort, review the information
in this section. Add tests as needed to your plan.
If you have SuiteApps installed in your account, make sure you test these applications in
Release Preview. For third-party applications installed in your account, please contact the
solution provider and inform them of your Release Preview dates. Make sure you test all critical
business workflows that rely on the third-party solution and inform the solution provider of
any issues you may find.

Test Your Web Store
Important: During the testing of your business workflows, you might have thoroughly
tested your Web Store. If you think there are areas that might have been
overlooked in the workflow testing effort, review the information in this
section. Add tests as needed to your plan.
Perform the following configuration procedures to test your web store in Release Preview.
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Important: To prepare for web store testing in Release Preview, in the following
procedure you will add a line to the hosts file. Be sure to remove this line after
you finish testing.

To test your web store:
1.

Open a command window.

2.

Type ping shopping.na1.beta.netsuite.com and press Enter to obtain the IP address for
Shopping.na1.beta.netsuite.com

3.

Edit the hosts file on your C drive:
a.

At the prompt in the command window, type
cd Windows/system32/drivers/etc/ and press Enter.

b.

Edit the hosts file by typing edit hosts and press Enter.

c.

Add a line to hosts file using the IP Address you obtained from the ping
shopping.na1.beta.netsuite.com command. For example:
64.89.45.224 mydomain.com

d.

Select File > Save.
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e.
4.

Select File > Exit.

Log in to your NetSuite account and go to Setup > Site Builder > Domains and specify the
following properties:
a.

Domain name = <mydomain.com>

b.

Hosted as = Web Store

c.

HTML Hosting Root = Live Hosting Files

The site or page should populate with the company name.
5.

Click Save.

6.

Go to Setup > Site Builder > Set Up Web Site. Verify that the URL for your custom domain
is indicated as Primary.

7.

Open a browser window. Visit the web store on your custom domain.

Note: If you visited this domain recently, you may have to clear the browser cookies.
8.

9.

Confirm you are viewing your site on the Release Preview shopping server.
a.

In your browser, select View > Source (or right-click and select View Page Source).

b.

At the bottom of the source code page, you should see the new version number for
the NetSuite release.

Test your web store.
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Important: Be sure to remove the line you added to the hosts file after you complete
web store testing.

Test SuiteAnalytics Connect
Important: During the testing of your business workflows, you might have thoroughly
tested SuiteAnalytics Connect. If you think there are areas that might have
been overlooked in the workflow testing effort, review the information in this
section. Add tests as needed to your plan.

Testing Your ODBC Connection
Perform the following configuration procedures to test your ODBC connection in Release
Preview.

Important: To prepare for ODBC testing, in the following procedure you will switch the
Service Host entry to connect to the Release Preview environment. Be sure
to switch the Service Host entry back to your production account after you
finish testing ODBC in Release Preview.

To test ODBC access in Release Preview:
1.

Log out of your current ODBC connection.

2.

In the Windows Control Panel, double-click Administrative Tools, and double-click Data
Source (ODBC).

3.

In the ODBC Data Source Administrator dialog, select the User DSN for the NetSuite
ODBC driver, and click Configure.

4.

In the Driver Setup dialog, change the Service Host entry from odbcserver.netsuite.com
to odbcserver.na1.beta.netsuite.com.

5.

Click OK in both dialogs.

6.

Reconnect your ODBC connection.

7.

Perform your ODBC tests.

Important: Be sure to switch the Service Host entry back to

odbcserver.netsuite.com to connect to your production account.
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